Failure to run html5test.com on SDK.

Failure to run html5test.com on SDK.

Postby jani.mikkonen_1 » Thu Aug 14, 2014 4:24 am

Started to work on a small prototype for a service few weeks ago and in order to verify what sort of stuff is working on STA enabled devices, i tried pointing the browser in SDK to http://html5test.com and i found out following:

If settings in the emulator is set to \"Common Emulator\", html5test.com does work and results to this:
http://html5test.com/s/c27e6a21e2741c0c.html

Choosing any other option, does not. Running html5test.com on the sdk will yield this error:

[img]https://pbs.twimg.com/media/Bu1IKXQIEAEXBE9.png:large[/img]

I had a talk with html5test.com crew and after small debugging, i got these replies:

\"createElement with unsupported type triggers an exception instead of an element of the HTMLUnknownElement type.\"
\"I believe this is a HTML5 spec violation.\"

So, question here is:

Is this known ?
Is this expected behaviour ?
Can i expect that this sort of issue might get addressed in updates?
jani.mikkonen_1
 
Posts: 3
Joined: Mon Jul 27, 2015 4:41 am

Failure to run html5test.com on SDK.

Postby Support_STA » Thu Aug 14, 2014 7:19 pm

Hi,

Thanks for your question.
In case you had talk with html5test.com team,
could you tell us know whatHTMLUnknownElement is created by createElement function? It will be nice for us when we forward to stakeholders.
Besides, STA Spec 3.0 (
Common Emulator) and remaining STA Specs are differently for sure. Maybe some types doesn't support yet except 3.0. So could you take an overview look for these document here.

Regards,
STA Support
Support_STA
 
Posts: 136
Joined: Fri Aug 09, 2013 3:56 am

Failure to run html5test.com on SDK.

Postby jani.mikkonen_1 » Fri Aug 15, 2014 3:39 am

Sorry but i'm having hard time understanding what is said here.

If i understand correctly, according to the specs of html5, createElement should not trow exception with unknown elements but instead return HTMLUnknownElement. But once again, im not 100% sure about the internals ..

jani.mikkonen_1
 
Posts: 3
Joined: Mon Jul 27, 2015 4:41 am

Failure to run html5test.com on SDK.

Postby Support_STA » Mon Aug 18, 2014 6:54 pm

Hi,

Thanks for your feedback. We just want to collect as much information as can before sending this for SDK Workgroup.
As soon as we receive their result, we will inform the answer for you.

Regards,
STA Support
Support_STA
 
Posts: 136
Joined: Fri Aug 09, 2013 3:56 am


Return to SDK questions



cron