Smooth Streaming + PlayReady on Philips Smart TVs

Smooth Streaming + PlayReady on Philips Smart TVs

Postby FedeOmoto » Mon Feb 03, 2014 8:44 am

Hi!

We're trying to play SS + PR content on Philips Smart TVs without success. The strange thing is that the same code works OK on LG Smart TVs (the only difference is that for Philips we're using the HTML5 Video instead of the media object).
Also, we've no problems when we play SS content without DRM on Philips.

We use license post-acquisition with the oipfDrmAgent, but noticed the following on Philips Smart TVs doing some tests:
-License pre-acquisition with a HTTPS LA_URL: our license servers don't receive any data.
-License pre-acquisition with a HTTP LA_URL: our license servers get the request and return the license (even so, we can't manage to play the content).
-License post-acquisition with a HTTPS LA_URL: our license servers don't receive any data.
-License post-acquisition overriding the LA_URL with HTTP (through oipfDrmAgent): our license servers don't receive any data.

On the other hand, both four tests work OK on LG Smart TVs.

Is this a known bug on Philips Smart TVs? Does it only works with an HTTP LA_URL? And, why does it doesn't work with license post-acquisition overriding the LA_URL with HTTP?

Thank you in advance,
Federico Omoto
FedeOmoto
 
Posts: 10
Joined: Mon Oct 28, 2013 1:03 pm

Smooth Streaming + PlayReady on Philips Smart TVs

Postby FedeOmoto » Mon Feb 03, 2014 8:44 am

Hi!

We're trying to play SS + PR content on Philips Smart TVs without success. The strange thing is that the same code works OK on LG Smart TVs (the only difference is that for Philips we're using the HTML5 Video instead of the media object).
Also, we've no problems when we play SS content without DRM on Philips.

We use license post-acquisition with the oipfDrmAgent, but noticed the following on Philips Smart TVs doing some tests:
-License pre-acquisition with a HTTPS LA_URL: our license servers don't receive any data.
-License pre-acquisition with a HTTP LA_URL: our license servers get the request and return the license (even so, we can't manage to play the content).
-License post-acquisition with a HTTPS LA_URL: our license servers don't receive any data.
-License post-acquisition overriding the LA_URL with HTTP (through oipfDrmAgent): our license servers don't receive any data.

On the other hand, both four tests work OK on LG Smart TVs.

Is this a known bug on Philips Smart TVs? Does it only works with an HTTP LA_URL? And, why does it doesn't work with license post-acquisition overriding the LA_URL with HTTP?

Thank you in advance,
Federico Omoto
FedeOmoto
 
Posts: 10
Joined: Mon Oct 28, 2013 1:03 pm

Re: Smooth Streaming + PlayReady on Philips Smart TVs

Postby Support_STA » Mon Feb 03, 2014 8:44 am

Hi,

Thank you for bringing this to our attention. We will investigat this problem and get back on this as soon as we know what is causing this.

Regards,
STA QA
Support_STA
 
Posts: 136
Joined: Fri Aug 09, 2013 3:56 am

Re: Smooth Streaming + PlayReady on Philips Smart TVs

Postby FedeOmoto » Mon Feb 03, 2014 8:44 am

Thank you for your quick answer!
Please let me know if you need more information or even if you need us to make some tests.

Regards,
Federico Omoto
FedeOmoto
 
Posts: 10
Joined: Mon Oct 28, 2013 1:03 pm

Re: Smooth Streaming + PlayReady on Philips Smart TVs

Postby Support_STA » Wed Feb 05, 2014 3:10 pm

Hi,

Thank you for bringing this to our attention. We will investigat this problem and get back on this as soon as we know what is causing this.

Regards,
STA QA
Support_STA
 
Posts: 136
Joined: Fri Aug 09, 2013 3:56 am

Re: Smooth Streaming + PlayReady on Philips Smart TVs

Postby FedeOmoto » Thu Feb 06, 2014 12:25 am

Thank you for your quick answer!
Please let me know if you need more information or even if you need us to make some tests.

Regards,
Federico Omoto
FedeOmoto
 
Posts: 10
Joined: Mon Oct 28, 2013 1:03 pm


Return to App development questions



cron